summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorU. Artie Eoff <ullysses.a.eoff@intel.com>2017-11-21 11:31:23 -0800
committerXiang, Haihao <haihao.xiang@intel.com>2017-11-21 14:07:59 -0800
commit6ca99be5042558035a78ffa87cfcd853611591cc (patch)
treee0373937246ab7b553422cc19b25b97f66c9d8a1 /configure.ac
parentfc2a6198fb5b1e7c0d345f7286ade49f3cc7f27c (diff)
downloadlibva-6ca99be5042558035a78ffa87cfcd853611591cc.tar.gz
configure: set strict default compiler flags
Use -Wall -Werror compiler flags for stricter compilation. Fixes #146 Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ad53d0a..0507d64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -301,6 +301,9 @@ if test "$USE_DRM:$USE_X11:$USE_WAYLAND" = "no:no:no"; then
AC_MSG_ERROR([Please select at least one backend (DRM, X11, Wayland)])
fi
+AC_SUBST([AM_CFLAGS], ["-Wall -Werror"])
+AC_SUBST([AM_CXXFLAGS], ["-Wall -Werror"])
+
AC_OUTPUT([
Makefile
doc/Makefile