summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean V Kelley <seanvk@posteo.de>2017-02-03 22:17:33 -0800
committerXiang, Haihao <haihao.xiang@intel.com>2017-02-06 10:41:38 +0800
commit81a2cf7de059954f9f026a6064f9dc4424a31196 (patch)
treea030148b2056cbfd3b69655b57f20ce9f6334f09 /configure.ac
parentc8d523bcc1e8cfbc432002908dc1e37de002ce78 (diff)
downloadlibva-81a2cf7de059954f9f026a6064f9dc4424a31196.tar.gz
config: Add va_messaging flag
on by default, but allows optional disabling. fixes #21 Signed-off-by: Sean V Kelley <seanvk@posteo.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 540bdce..b14d624 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,6 +153,11 @@ AC_ARG_ENABLE([wayland],
[build with VA/Wayland API support @<:@default=yes@:>@])],
[], [enable_wayland="yes"])
+AC_ARG_ENABLE([va-messaging],
+ [AC_HELP_STRING([--enable-va-messaging],
+ [build with va info and error messaging @<:@default=yes@:>@])],
+ [], [enable_va_messaging="yes"])
+
AC_ARG_ENABLE(dummy-driver,
[AC_HELP_STRING([--enable-dummy-driver],
[build dummy video driver @<:@default=yes@:>@])],
@@ -186,6 +191,11 @@ if test "$enable_docs" = "yes"; then
fi
AM_CONDITIONAL(ENABLE_DOCS, test "$enable_docs" = "yes")
+# Check for va messaging
+if test "$enable_va_messaging" = "yes"; then
+ AC_DEFINE([ENABLE_VA_MESSAGING], [1], [Defined to 1 if va messaging is needed])
+fi
+
# Check for __attribute__((visibility()))
AC_CACHE_CHECK([whether __attribute__((visibility())) is supported],
ac_cv_have_gnuc_visibility_attribute,
@@ -340,4 +350,5 @@ echo Default driver path .............. : $LIBVA_DRIVERS_PATH
echo Extra window systems ............. : $BACKENDS
echo Build dummy driver ............... : $enable_dummy_driver
echo Build documentation .............. : $enable_docs
+echo Build with messaging ............. : $enable_va_messaging
echo