summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorU. Artie Eoff <ullysses.a.eoff@intel.com>2017-11-27 09:47:02 -0800
committerXiang, Haihao <haihao.xiang@intel.com>2017-11-27 10:43:26 -0800
commitdf544cd5a31e54d4cbd33a391795a8747ddaf789 (patch)
treea39998ba77edea7c4a582f52140ae7f239c079d3 /configure.ac
parent51e98b1224794a44ba097baa7a1b4e35c3596d0c (diff)
downloadlibva-df544cd5a31e54d4cbd33a391795a8747ddaf789.tar.gz
Revert "configure: set strict default compiler flags"
This reverts commit 6ca99be5042558035a78ffa87cfcd853611591cc. Strict compilation flags are not consistent across different versions of GCC and cause issues for users with older GCC versions. Since we have little control over which compiler version is used by user, ensuring that strict compilation works properly across all known used compilers would be a maintenance headache. Instead, don't enforce strict compilation and let users choose when to enforce it via user-defined C/CXXFLAGS. Fixes #152 Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0507d64..ad53d0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -301,9 +301,6 @@ if test "$USE_DRM:$USE_X11:$USE_WAYLAND" = "no:no:no"; then
AC_MSG_ERROR([Please select at least one backend (DRM, X11, Wayland)])
fi
-AC_SUBST([AM_CFLAGS], ["-Wall -Werror"])
-AC_SUBST([AM_CXXFLAGS], ["-Wall -Werror"])
-
AC_OUTPUT([
Makefile
doc/Makefile