summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-02-23 16:10:09 +0200
committerSean V. Kelley <seanvk@users.noreply.github.com>2017-02-24 14:30:14 -0800
commite6133276ebbf9b3b8a4faae18a7038ad744028e3 (patch)
tree38e8a02417524fc4b7a4340a826f5917480a0ba7 /configure.ac
parentb832b37c6a6f7ff69a4ea4656007827a1b7e67e8 (diff)
downloadlibva-e6133276ebbf9b3b8a4faae18a7038ad744028e3.tar.gz
wayland: Don't commit and ship generated files
I believe shipping wayland-drm-client-protocol.h is wrong: The header should always be generated by the wayland-scanner that matches the runtime wayland version. Currently when someone clones the repo and builds, the shipped version is used. Remove wayland-drm-client-protocol.h from source tree, modify the build so the header is considered a built source file, and make configure fail if wayland is enabled but wayland-scanner is not found. Fixes #34. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b14d624..8e1a5fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -292,6 +292,9 @@ if test "$enable_wayland" = "yes"; then
WAYLAND_PREFIX=`$PKG_CONFIG --variable=prefix wayland-client`
AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner],,
[${WAYLAND_PREFIX}/bin$PATH_SEPARATOR$PATH])
+ if test "x$WAYLAND_SCANNER" = "x"; then
+ AC_MSG_ERROR([wayland-scanner not found: Install it or use --disable-wayland])
+ fi
AC_DEFINE([HAVE_VA_WAYLAND], [1],
[Defined to 1 if VA/Wayland API is built])