summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2018-01-19 19:12:29 +0100
committerXiang, Haihao <haihao.xiang@intel.com>2018-02-01 09:24:11 +0800
commitda5a08b53f50aec22f0fc11fe369f94b99144c5e (patch)
treed0bb7192087f7548ecda0a0785689eb81a133577 /doc/Makefile.am
parente2f24a6932489b2e971168622c15dcdaf73a2d36 (diff)
downloadlibva-da5a08b53f50aec22f0fc11fe369f94b99144c5e.tar.gz
doc: use Doxyfile template
Instead of passing environment variables to the Doxygen process, Doxyfile will be autogenerated from Doxyfile.in template.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am21
1 files changed, 13 insertions, 8 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index d6854d2..c9b5343 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -24,7 +24,7 @@ all: html
install-data-local: install-html
EXTRA_DIST = \
- Doxyfile \
+ Doxyfile.in \
$(NULL)
VA_HEADER_DIR = $(top_srcdir)/va
@@ -47,13 +47,18 @@ VA_HEADER_FILES = \
$(NULL)
VA_HTML_FOOTER = va_footer.html
-VA_HTML_FRAGMENTS = $(VA_HTML_FOOTER)
-export VA_HEADER_DIR
-export VA_HEADER_FILES
-export VA_HTML_FOOTER
-html-out/index.html: Doxyfile $(VA_HEADER_FILES) $(VA_HTML_FRAGMENTS)
- $(DOXYGEN) $<
+Doxyfile: Doxyfile.in $(VA_HEADER_FILES) $(VA_HTML_FOOTER)
+ $(AM_V_GEN) $(SED) \
+ -e "s:\@PACKAGE_VERSION\@:$(PACKAGE_VERSION):" \
+ -e "s:\@VA_HEADER_DIR\@:$(VA_HEADER_DIR):" \
+ -e "s:\@VA_HEADER_FILES\@:$(VA_HEADER_FILES):" \
+ -e "s:\@VA_HTML_FOOTER\@:$(VA_HTML_FOOTER):" \
+ -e "s:\@OUTDIR\@::" \
+ $< > $@
+
+html-out/index.html: Doxyfile
+ $(AM_V_GEN) $(DOXYGEN)
if ENABLE_DOCS
html: html-out/index.html
@@ -72,4 +77,4 @@ uninstall-local:
endif
# Extra clean files so that maintainer-clean removes *everything*
-MAINTAINERCLEANFILES = Makefile.in
+MAINTAINERCLEANFILES = Makefile.in Doxyfile