summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2018-01-19 20:42:11 +0100
committerXiang, Haihao <haihao.xiang@intel.com>2018-02-01 09:24:11 +0800
commit2e41bfd7ad000a69fb3f27b7b81ba52ebafedbf2 (patch)
tree9f245118a2d80882ab4afc702688e006a0ac31a9 /meson.build
parentfc20e7c1bd71feaee46624220daf48bae817a19e (diff)
downloadlibva-2e41bfd7ad000a69fb3f27b7b81ba52ebafedbf2.tar.gz
build: meson: build documentation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f7ae4cd..d24a597 100644
--- a/meson.build
+++ b/meson.build
@@ -115,3 +115,9 @@ endif
subdir('va')
subdir('pkgconfig')
+
+doxygen = find_program('doxygen', required: false)
+
+if get_option('enable_docs') and doxygen.found()
+ subdir('doc')
+endif