summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2019-01-25 12:24:47 +0100
committerXinfengZhang <carl.zhang@intel.com>2019-03-04 23:02:01 -0800
commita99bab12713b67a3f9281b2945df53e7b23c830f (patch)
treed0c039a6c2821af6bc7de84b53923adc05693cee /meson.build
parent16d32656d62132cb54969340d375c5e3ca51bd4f (diff)
downloadlibva-a99bab12713b67a3f9281b2945df53e7b23c830f.tar.gz
build: meson: enables va messaging and visibility
This patch syncs with the defined compiler flags in autotools: the enable of VA messaging and the compiler's support to visibility attribute. Fixes: #275
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1407354..b3270dd 100644
--- a/meson.build
+++ b/meson.build
@@ -108,6 +108,15 @@ if get_option('with_wayland') != 'no'
WITH_WAYLAND = wayland_dep.found()
endif
+va_c_args = []
+if get_option('enable_va_messaging')
+ va_c_args += ['-DENABLE_VA_MESSAGING=1']
+endif
+
+# Symbol visibility
+if cc.has_argument('-fvisibility=hidden')
+ va_c_args += ['-DHAVE_GNUC_VISIBILITY_ATTRIBUTE']
+endif
if (not WITH_DRM and not WITH_X11 and not WITH_WAYLAND)
error('Please install at least one backend dev files (DRM, X11, Wayland)')