summaryrefslogtreecommitdiff
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-10-14 17:31:24 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-10-17 10:15:11 +0200
commit254d954c85e2eb3d0f79e18a9abaf5fc4182af74 (patch)
treebd042cf773e12ecbf71872dc041c2b75c3cf9f5c /pkgconfig/Makefile.am
parentfffd4a187101d201a5e0a3de0fc1f7a83e648be0 (diff)
downloadlibva-254d954c85e2eb3d0f79e18a9abaf5fc4182af74.tar.gz
pkgconfig: move files to a specific directory.
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
new file mode 100644
index 0000000..f595413
--- /dev/null
+++ b/pkgconfig/Makefile.am
@@ -0,0 +1,47 @@
+# Copyright (c) 2007 Intel Corporation. All Rights Reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the
+# "Software"), to deal in the Software without restriction, including
+# without limitation the rights to use, copy, modify, merge, publish,
+# distribute, sub license, and/or sell copies of the Software, and to
+# permit persons to whom the Software is furnished to do so, subject to
+# the following conditions:
+#
+# The above copyright notice and this permission notice (including the
+# next paragraph) shall be included in all copies or substantial portions
+# of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
+# IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS SUPPLIERS BE LIABLE FOR
+# ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+# TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+# SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+pcfiles = libva.pc
+pcfiles += libva-tpi.pc
+pcfiles += libva-x11.pc
+if USE_GLX
+pcfiles += libva-glx.pc
+endif
+if USE_EGL
+pcfiles += libva-egl.pc
+endif
+
+all_pcfiles_in = libva.pc.in
+all_pcfiles_in += libva-tpi.pc.in
+all_pcfiles_in += libva-x11.pc.in
+all_pcfiles_in += libva-glx.pc.in
+all_pcfiles_in += libva-egl.pc.in
+
+pkgconfigdir = @pkgconfigdir@
+pkgconfig_DATA = $(pcfiles)
+
+EXTRA_DIST = $(all_pcfiles_in)
+
+DISTCLEANFILES = $(pcfiles)
+
+# Extra clean files so that maintainer-clean removes *everything*
+MAINTAINERCLEANFILES = Makefile.in