summaryrefslogtreecommitdiff
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
authorXiang, Haihao <haihao.xiang@intel.com>2017-06-19 16:25:39 +0800
committerXiang, Haihao <haihao.xiang@intel.com>2017-09-27 12:48:16 +0800
commitfc277b8f5eb92a94b4a9112eba591f87072786ce (patch)
tree8006cd70fb0cdfaef79336005b036d7c916ea9da /pkgconfig/Makefile.am
parent4ba33717a4f3aafaec8ed6c21e85db2987d67276 (diff)
downloadlibva-fc277b8f5eb92a94b4a9112eba591f87072786ce.tar.gz
Delete libva-tpi and libva-egl backends
The APIs/data structures defined in va_tpi.h and va_egl.h are used to implement buffer sharing between libva and the 3rd party libraries. We have an official buffer sharing machnism in VA core, so libva-tpi and libva-egl are unnecessary any more. However va_egl.h or va_tpi.h is included uselessly in a few places, e.g. https://github.com/01org/libyami/blob/apache/vaapi/vaapidisplay.h#L22 So va_egl.h and va_tpi.h are kept with a deprecation warning message. Signed-off-by: Xiang, Haihao <haihao.xiang@intel.com>
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
index a3435a4..4582531 100644
--- a/pkgconfig/Makefile.am
+++ b/pkgconfig/Makefile.am
@@ -21,7 +21,6 @@
# SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
pcfiles = libva.pc
-pcfiles += libva-tpi.pc
if USE_DRM
pcfiles += libva-drm.pc
endif
@@ -31,19 +30,14 @@ endif
if USE_GLX
pcfiles += libva-glx.pc
endif
-if USE_EGL
-pcfiles += libva-egl.pc
-endif
if USE_WAYLAND
pcfiles += libva-wayland.pc
endif
all_pcfiles_in = libva.pc.in
-all_pcfiles_in += libva-tpi.pc.in
all_pcfiles_in += libva-drm.pc.in
all_pcfiles_in += libva-x11.pc.in
all_pcfiles_in += libva-glx.pc.in
-all_pcfiles_in += libva-egl.pc.in
all_pcfiles_in += libva-wayland.pc.in
pkgconfigdir = @pkgconfigdir@