summaryrefslogtreecommitdiff
path: root/va/Makefile.am
diff options
context:
space:
mode:
authorZhao Yakui <yakui.zhao@intel.com>2013-04-28 09:03:43 +0800
committerXiang, Haihao <haihao.xiang@intel.com>2013-06-25 15:11:01 +0800
commite8a2b81744347809230fdc510c6135bbcef9cc22 (patch)
treeffaed50215f5ca0c82dcc729cc0513058d33cf76 /va/Makefile.am
parent5d3d89f556f72778de9985f5ba4a65f6dd93c1ff (diff)
downloadlibva-e8a2b81744347809230fdc510c6135bbcef9cc22.tar.gz
Remove the EGL dependency on X11
Otherwise when x11 is disabled, it can't be compiled correctly. Signed-off-by: Zhao Yakui <yakui.zhao@intel.com>
Diffstat (limited to 'va/Makefile.am')
-rw-r--r--va/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/va/Makefile.am b/va/Makefile.am
index 59b6c64..ba429fa 100644
--- a/va/Makefile.am
+++ b/va/Makefile.am
@@ -113,8 +113,8 @@ SUBDIRS += egl
lib_LTLIBRARIES += libva-egl.la
libva_egl_la_SOURCES =
libva_egl_la_LDFLAGS = $(LDADD)
-libva_egl_la_DEPENDENCIES = libva.la egl/libva_egl.la libva-x11.la
-libva_egl_la_LIBADD = libva.la egl/libva_egl.la libva-x11.la \
+libva_egl_la_DEPENDENCIES = libva.la egl/libva_egl.la
+libva_egl_la_LIBADD = libva.la egl/libva_egl.la \
$(EGL_LIBS) -ldl
endif