summaryrefslogtreecommitdiff
path: root/debian.upstream
diff options
context:
space:
mode:
Diffstat (limited to 'debian.upstream')
-rw-r--r--debian.upstream/Makefile.am32
-rw-r--r--debian.upstream/README.Debian7
-rw-r--r--debian.upstream/changelog.in5
-rw-r--r--debian.upstream/compat1
-rw-r--r--debian.upstream/control.in52
-rw-r--r--debian.upstream/copyright44
-rw-r--r--debian.upstream/libva-dev.dirs2
-rw-r--r--debian.upstream/libva-dev.install3
-rw-r--r--debian.upstream/libva1.dirs1
-rw-r--r--debian.upstream/libva1.install2
-rwxr-xr-xdebian.upstream/rules15
11 files changed, 164 insertions, 0 deletions
diff --git a/debian.upstream/Makefile.am b/debian.upstream/Makefile.am
new file mode 100644
index 0000000..56dc98a
--- /dev/null
+++ b/debian.upstream/Makefile.am
@@ -0,0 +1,32 @@
+DEBIANFILES = \
+ README.Debian \
+ changelog.in \
+ compat \
+ control.in \
+ copyright \
+ libva-dev.dirs \
+ libva-dev.install \
+ libva1.dirs \
+ libva1.install \
+ rules \
+ $(NULL)
+
+DEBIANGENFILES = \
+ changelog \
+ control \
+ $(NULL)
+
+EXTRA_DIST = $(DEBIANFILES)
+
+dist_noinst_DATA = $(DEBIANGENFILES)
+
+# Extra clean files so that maintainer-clean removes *everything*
+MAINTAINERCLEANFILES = Makefile.in $(DEBIANGENFILES)
+
+$(DEBIANGENFILES): %: %.in Makefile
+ -sed \
+ -e 's|\@DATE\@|'"`LC_ALL=C date +'%a, %d %b %Y %X %z'`"'|' \
+ -e 's|\@LIBDRM_VERSION\@|$(LIBDRM_VERSION)|' \
+ -e 's|\@LIBVA_PACKAGE_VERSION\@|$(LIBVA_PACKAGE_VERSION)|' \
+ -e 's|\@PACKAGE_VERSION\@|$(PACKAGE_VERSION)|' \
+ $< > $@
diff --git a/debian.upstream/README.Debian b/debian.upstream/README.Debian
new file mode 100644
index 0000000..d10d702
--- /dev/null
+++ b/debian.upstream/README.Debian
@@ -0,0 +1,7 @@
+libva for Debian
+----------------
+
+This library implements the Video Acceleration (VA) API for Linux.
+It will load a hardware dependendent video acceleration driver.
+
+ -- Waldo Bastian <waldo.bastian@intel.com> Mon, 18 Jun 2007 21:35:31 -0700
diff --git a/debian.upstream/changelog.in b/debian.upstream/changelog.in
new file mode 100644
index 0000000..397b5eb
--- /dev/null
+++ b/debian.upstream/changelog.in
@@ -0,0 +1,5 @@
+libva (@PACKAGE_VERSION@-1) unstable; urgency=low
+
+ * Autogenerated package, see NEWS file for ChangeLog.
+
+ -- Gwenole Beauchesne <gwenole.beauchesne@intel.com> @DATE@
diff --git a/debian.upstream/compat b/debian.upstream/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian.upstream/compat
@@ -0,0 +1 @@
+5
diff --git a/debian.upstream/control.in b/debian.upstream/control.in
new file mode 100644
index 0000000..f8291c5
--- /dev/null
+++ b/debian.upstream/control.in
@@ -0,0 +1,52 @@
+Source: libva
+Priority: extra
+Maintainer: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
+Build-Depends: automake,
+ autotools-dev,
+ cdbs,
+ debhelper (>= 5),
+ libdrm-dev (>= @LIBDRM_VERSION@),
+ libgl-dev,
+ libtool,
+ libxext-dev,
+ libxfixes-dev,
+ pkg-config,
+ x11proto-xext-dev
+Standards-Version: 3.7.2
+Section: libs
+
+Package: libva-dev
+Section: libdevel
+Architecture: any
+Depends: libva1 (= ${binary:Version}),
+ libdrm-dev (>= @LIBDRM_VERSION@),
+ libgl-dev,
+ pkg-config
+Conflicts: libva-0.29-dev
+Replaces: libva-0.29-dev
+Description: Video Acceleration (VA) API for Linux -- development files
+ The libva library implements the Video Acceleration (VA) API for Linux.
+ The library loads a hardware dependendent driver.
+ .
+ This package provides the development environment for libva.
+
+Package: libva1
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}
+Conflicts: libva-0.29-0
+Replaces: libva-0.29-0
+Provides: libva-0.29-0
+Description: Video Acceleration (VA) API for Linux -- runtime
+ The libva library implements the Video Acceleration (VA) API for Linux.
+ The library loads a hardware dependendent driver.
+
+Package: libva1-dbg
+Section: libdevel
+Architecture: any
+Depends: libva1 (= ${Source-Version})
+Description: Video Acceleration (VA) API for Linux -- runtime
+ The libva library implements the Video Acceleration (VA) API for Linux.
+ The library loads a hardware dependendent driver.
+ .
+ This package contains the debug files.
diff --git a/debian.upstream/copyright b/debian.upstream/copyright
new file mode 100644
index 0000000..38b60ef
--- /dev/null
+++ b/debian.upstream/copyright
@@ -0,0 +1,44 @@
+This package was debianized by Waldo Bastian <waldo.bastian@intel.com> on
+Mon, 18 Jun 2007 21:35:31 -0700.
+
+It was downloaded from <url://example.com>
+
+Upstream Author(s):
+
+ Waldo Bastian <waldo.bastian@intel.com>
+ Jonathan Bian <jonathan.bian@intel.com>
+
+Copyright:
+
+ (C) Copyright IBM Corporation 2004
+ Copyright 1998-1999 Precision Insight, Inc., Cedar Park, Texas.
+ Copyright 2000 VA Linux Systems, Inc.
+ Copyright 2007 Intel Corportation
+
+License:
+
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish,
+ distribute, sub license, and/or sell copies of the Software, and to
+ permit persons to whom the Software is furnished to do so, subject to
+ the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial portions
+ of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
+ IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS SUPPLIERS BE LIABLE FOR
+ ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+The Debian packaging is (C) 2007, Intel Corporation and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
+
+# Please also look if there are files or directories which have a
+# different copyright/license attached and list them here.
diff --git a/debian.upstream/libva-dev.dirs b/debian.upstream/libva-dev.dirs
new file mode 100644
index 0000000..4418816
--- /dev/null
+++ b/debian.upstream/libva-dev.dirs
@@ -0,0 +1,2 @@
+usr/lib
+usr/include
diff --git a/debian.upstream/libva-dev.install b/debian.upstream/libva-dev.install
new file mode 100644
index 0000000..2611cdb
--- /dev/null
+++ b/debian.upstream/libva-dev.install
@@ -0,0 +1,3 @@
+debian/tmp/usr/include/va/va*.h
+debian/tmp/usr/lib/libva*.so
+debian/tmp/usr/lib/pkgconfig/libva*.pc
diff --git a/debian.upstream/libva1.dirs b/debian.upstream/libva1.dirs
new file mode 100644
index 0000000..6845771
--- /dev/null
+++ b/debian.upstream/libva1.dirs
@@ -0,0 +1 @@
+usr/lib
diff --git a/debian.upstream/libva1.install b/debian.upstream/libva1.install
new file mode 100644
index 0000000..ddfd8ed
--- /dev/null
+++ b/debian.upstream/libva1.install
@@ -0,0 +1,2 @@
+debian/tmp/usr/lib/libva.so.*
+debian/tmp/usr/lib/libva-*.so.*
diff --git a/debian.upstream/rules b/debian.upstream/rules
new file mode 100755
index 0000000..27b2639
--- /dev/null
+++ b/debian.upstream/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+# Allow SMP build
+ifeq ($(DEBIAN_BUILD_NCPUS),)
+ DEBIAN_BUILD_NCPUS = $(shell /usr/bin/getconf _NPROCESSORS_ONLN)
+endif
+ifneq ($(DEBIAN_BUILD_NCPUS),)
+ EXTRA_MAKE_FLAGS += -j$(DEBIAN_BUILD_NCPUS)
+endif
+MAKE += $(EXTRA_MAKE_FLAGS)