summaryrefslogtreecommitdiff
path: root/va/egl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'va/egl/Makefile.am')
-rw-r--r--va/egl/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/va/egl/Makefile.am b/va/egl/Makefile.am
new file mode 100644
index 0000000..5b5abd4
--- /dev/null
+++ b/va/egl/Makefile.am
@@ -0,0 +1,38 @@
+# Copyright (C) 2009 Splitted-Desktop Systems. All Rights Reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the
+# "Software"), to deal in the Software without restriction, including
+# without limitation the rights to use, copy, modify, merge, publish,
+# distribute, sub license, and/or sell copies of the Software, and to
+# permit persons to whom the Software is furnished to do so, subject to
+# the following conditions:
+#
+# The above copyright notice and this permission notice (including the
+# next paragraph) shall be included in all copies or substantial portions
+# of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
+# IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS SUPPLIERS BE LIABLE FOR
+# ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+# TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+# SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+AM_CFLAGS = -DLINUX -I$(top_srcdir)/va -I$(top_srcdir)/va/x11
+
+source_c = \
+ va_egl.c
+
+source_h = \
+ va_egl.h \
+ va_backend_egl.h
+
+source_h_priv =
+
+noinst_LTLIBRARIES = libva_egl.la
+libva_eglincludedir = ${includedir}/va
+libva_eglinclude_HEADERS = $(source_h)
+libva_egl_la_SOURCES = $(source_c)
+noinst_HEADERS = $(source_h_priv)