summaryrefslogtreecommitdiff
path: root/docs/meson.build
diff options
context:
space:
mode:
authorPeter Krempa <pkrempa@redhat.com>2022-05-31 15:15:57 +0200
committerPeter Krempa <pkrempa@redhat.com>2022-06-01 12:27:10 +0200
commit84521246691b1d4e3ecb5ecf70e1a858a7999a4f (patch)
tree10ad3287bbe18d1926f4288bdae6e96012b78c14 /docs/meson.build
parentdcff02d797641f9fcf6cfe2edc14d4eae4136f4e (diff)
downloadlibvirt-84521246691b1d4e3ecb5ecf70e1a858a7999a4f.tar.gz
docs: Add HTML reference checker
In many cases we move around or rename internal anchors which may break links leading to the content. docutils handle the case of links inside a document, but we are lacking the same form of checking between documents. Introduce a script which cross-checks all the anchors and links in HTML output files and prints problems and use it as a test case for the 'docs' directory. Signed-off-by: Peter Krempa <pkrempa@redhat.com> Reviewed-by: Ján Tomko <jtomko@redhat.com>
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/docs/meson.build b/docs/meson.build
index d71f6006dd..cb70ef6084 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -350,3 +350,14 @@ run_target(
],
depends: install_web_deps,
)
+
+test(
+ 'check-html-references',
+ python3_prog,
+ args: [
+ check_html_references_prog.path(),
+ '--prefix',
+ meson.build_root() / 'docs'
+ ],
+ env: runutf8,
+)