summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2022-10-07 09:31:32 +0200
committerMichal Privoznik <mprivozn@redhat.com>2022-10-10 15:06:09 +0200
commit5ecdcf85416c51c8fbbf4c79a72ad219854b039e (patch)
treed081f67ffe29cfdca519a099aa3f4f840077123f /meson.build
parent190486519a2d791feb31124bff5a5179fca83e25 (diff)
downloadlibvirt-5ecdcf85416c51c8fbbf4c79a72ad219854b039e.tar.gz
meson: Replace meson.build_root() with meson.project_build_root()
The build_root() method is deprecated in 0.56.0 and we're recommended to use project_build_root() instead. Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Reviewed-by: Ján Tomko <jtomko@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 0f4650f467..b7a0e4726f 100644
--- a/meson.build
+++ b/meson.build
@@ -26,7 +26,7 @@ endif
conf = configuration_data()
conf.set('_GNU_SOURCE', 1)
-conf.set_quoted('abs_top_builddir', meson.build_root())
+conf.set_quoted('abs_top_builddir', meson.project_build_root())
conf.set_quoted('abs_top_srcdir', meson.source_root())
conf.set_quoted('PACKAGE', meson.project_name())
conf.set_quoted('PACKAGE_NAME', meson.project_name())
@@ -2171,7 +2171,7 @@ if git
foreach file : dist_files
meson.add_dist_script(
meson_python_prog.path(), python3_prog.path(), meson_dist_prog.path(),
- meson.build_root(), file
+ meson.project_build_root(), file
)
endforeach
endif
@@ -2183,8 +2183,8 @@ configure_file(output: 'meson-config.h', configuration: conf)
# generate run helper
run_conf = configuration_data({
- 'abs_builddir': meson.build_root(),
- 'abs_top_builddir': meson.build_root(),
+ 'abs_builddir': meson.project_build_root(),
+ 'abs_top_builddir': meson.project_build_root(),
})
configure_file(