summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAndrea Bolognani <abologna@redhat.com>2022-02-01 18:56:26 +0100
committerAndrea Bolognani <abologna@redhat.com>2022-02-03 13:19:23 +0100
commit9f2d3cb472fd4d86dc4de5d57fcf8acb14e33e00 (patch)
tree76d3a3d88d34479223230bf98b6191fe46c2ad24 /meson.build
parent7714034ecd81b9c4e01df935ce2836f3efaed616 (diff)
downloadlibvirt-9f2d3cb472fd4d86dc4de5d57fcf8acb14e33e00.tar.gz
meson: Don't overwrite includedir
The current implementation of the workaround for yajl's broken pkg-config file accidentally overwrites the value of includedir that is later used by the installation process. Rename the local variable to avoid this issue. Fixes: c97075e1e46e9305d62620d8b05046aae0139438 Closes: https://gitlab.com/libvirt/libvirt/-/issues/271 Signed-off-by: Andrea Bolognani <abologna@redhat.com> Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 0e6f0f22fc..9016c0458a 100644
--- a/meson.build
+++ b/meson.build
@@ -1325,18 +1325,18 @@ if yajl_dep.found()
#
# [1] https://github.com/Homebrew/homebrew-core/pull/74516
if host_machine.system() != 'linux'
- includedir = yajl_dep.get_pkgconfig_variable('includedir')
- if includedir.contains('include/yajl')
+ yajl_includedir = yajl_dep.get_pkgconfig_variable('includedir')
+ if yajl_includedir.contains('include/yajl')
rc = run_command(
'python3', '-c',
'print("@0@".replace("@1@", "@2@"))'.format(
- includedir, 'include/yajl', 'include',
+ yajl_includedir, 'include/yajl', 'include',
),
check: true,
)
- includedir = rc.stdout().strip()
+ yajl_includedir = rc.stdout().strip()
yajl_dep = declare_dependency(
- compile_args: [ '-I' + includedir ],
+ compile_args: [ '-I' + yajl_includedir ],
dependencies: [ yajl_dep ],
)
endif