summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Krempa <pkrempa@redhat.com>2022-09-09 16:49:14 +0200
committerPeter Krempa <pkrempa@redhat.com>2022-09-09 16:49:21 +0200
commitb48469fcdb42cea237578e000cfb82b13f05b0ff (patch)
treed55ac77d455571e5c875ffc10b0ceea766b27cf2 /meson.build
parent46302172d47709b169c4b9b4cd6a4847fc2f0b4c (diff)
downloadlibvirt-b48469fcdb42cea237578e000cfb82b13f05b0ff.tar.gz
Revert "build: Decrease maximum stack frame size to 2048"
The bhyve driver still has some frames larger than 2048 bytes, so we need to keep the limit as is. The CI failure was masked by the Freebsd-13 failing for unrelated reasons. This reverts commit 46302172d47709b169c4b9b4cd6a4847fc2f0b4c Signed-off-by: Peter Krempa <pkrempa@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9d3703a321..ed9f4b3f70 100644
--- a/meson.build
+++ b/meson.build
@@ -226,7 +226,7 @@ alloc_max = run_command(
)
# sanitizer instrumentation may enlarge stack frames
-stack_frame_size = get_option('b_sanitize') == 'none' ? 2048 : 32768
+stack_frame_size = get_option('b_sanitize') == 'none' ? 4096 : 32768
# array_bounds=2 check triggers false positive on some GCC
# versions when using sanitizers. Seen on Fedora 34 with