summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2023-04-17 15:53:56 +0400
committerMichal Privoznik <mprivozn@redhat.com>2023-04-17 15:02:22 +0200
commitc69bbd14fa26749e1bb418f85a16e4f81447f077 (patch)
tree5dee955a88afaae4ed4427951ff485641bb701c2 /meson.build
parent7cbbd45af115c24dba1b1be9631a32d6215ff0cc (diff)
downloadlibvirt-c69bbd14fa26749e1bb418f85a16e4f81447f077.tar.gz
meson: don't look for unix paths on win32
Or meson will complain with: ../meson.build:770:2: ERROR: Search directory /sbin is not an absolute path. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Reviewed-by: Michal Privoznik <mprivozn@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 9 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 47ec7fcb74..f7f31a278d 100644
--- a/meson.build
+++ b/meson.build
@@ -742,11 +742,15 @@ conf.set('SIZEOF_LONG', cc.sizeof('long'))
# Where we look for daemons and admin binaries during configure
-libvirt_sbin_path = [
- '/sbin',
- '/usr/sbin',
- '/usr/local/sbin',
-]
+libvirt_sbin_path = []
+
+if host_machine.system() != 'windows'
+ libvirt_sbin_path += [
+ '/sbin',
+ '/usr/sbin',
+ '/usr/local/sbin',
+ ]
+endif
# required programs check