summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorErik Skultety <eskultet@redhat.com>2015-09-23 15:17:35 +0200
committerErik Skultety <eskultet@redhat.com>2015-09-24 16:58:28 +0200
commit2d9fcb3102e0877afc574da17baba2713e14899a (patch)
treeb79f0618be629ebfed2f89214852901c56f728d9 /tools/Makefile.am
parenta73c67b6cc4d2404b0c2d2af3cbd37f79b701f42 (diff)
downloadlibvirt-2d9fcb3102e0877afc574da17baba2713e14899a.tar.gz
vsh: create a noinstall libvirt_shell library
Instead of referencing vsh sources in all relevant client targets, create a library that the client can link against.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am28
1 files changed, 20 insertions, 8 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 03e933949e..0a00cee04a 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -129,6 +129,24 @@ virt-sanlock-cleanup.8: virt-sanlock-cleanup.in $(top_srcdir)/configure.ac
&& if grep 'POD ERROR' $(srcdir)/$@ ; then \
rm $(srcdir)/$@; exit 1; fi
+noinst_LTLIBRARIES = libvirt_shell.la
+libvirt_shell_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(PIE_CFLAGS) \
+ $(READLINE_CFLAGS) \
+ $(LIBXML_CFLAGS) \
+ $(NULL)
+libvirt_shell_la_LDFLAGS = \
+ $(AM_LDFLAGS) \
+ $(PIE_LDFLAGS) \
+ $(COVERAGE_LDFLAGS) \
+ $(NULL)
+libvirt_shell_la_LIBADD = \
+ $(LIBXML_LIBS) \
+ ../gnulib/lib/libgnu.la \
+ $(NULL)
+libvirt_shell_la_SOURCES = vsh.c vsh.h
+
virt_host_validate_SOURCES = \
virt-host-validate.c \
virt-host-validate-common.c virt-host-validate-common.h \
@@ -179,11 +197,7 @@ virt_login_shell_CFLAGS = \
$(PIE_CFLAGS) \
$(COVERAGE_CFLAGS)
-virt_shell_SOURCES = \
- vsh.c vsh.h
-
virsh_SOURCES = \
- $(virt_shell_SOURCES) \
virsh.c virsh.h \
virsh-console.c virsh-console.h \
virsh-domain.c virsh-domain.h \
@@ -209,15 +223,13 @@ virsh_LDADD = \
../src/libvirt.la \
../src/libvirt-lxc.la \
../src/libvirt-qemu.la \
- ../gnulib/lib/libgnu.la \
- $(LIBXML_LIBS) \
+ libvirt_shell.la \
$(VIRSH_LIBS)
virsh_CFLAGS = \
$(WARN_CFLAGS) \
$(PIE_CFLAGS) \
$(COVERAGE_CFLAGS) \
- $(LIBXML_CFLAGS) \
- $(READLINE_CFLAGS)
+ $(LIBXML_CFLAGS)
BUILT_SOURCES =
if WITH_WIN_ICON