summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomasvs@xiph.org>2004-07-26 13:31:38 +0000
committerThomas Vander Stichele <thomasvs@xiph.org>2004-07-26 13:31:38 +0000
commitce13174d4aa17a060b9458a0cabb636a2dca5323 (patch)
tree055f72668ced9956b89ed1e5c0879bb38ec7478e /configure.in
parent96c06653bb93ae4d2759ddb9fc13550e42bac99e (diff)
downloadlibvorbis-git-ce13174d4aa17a060b9458a0cabb636a2dca5323.tar.gz
This patch fixes a few autotools issues with vorbis svn
* error out on autotools failures so warnings are caught early on * move around AC_CANONICAL_HOST to squash warning * add AC_CANONICAL_TARGET * don't squash LIBS but set VORBIS_LIBS instead * clean up AC_OUTPUT * AUTOMAKE_OPTIONS = foreign only needs to be done toplevel (this can be verified by checking Makefile's generated in other directories and seeing that the var isn't used) * use OGG_LIBS and VORBIS_LIBS in Makefile.am svn path=/trunk/vorbis/; revision=7345
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 27 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 3758a9d0..cfe3ca56 100644
--- a/configure.in
+++ b/configure.in
@@ -5,6 +5,10 @@ dnl Initialization and Versioning
dnl ------------------------------------------------
AC_INIT(lib/mdct.c)
+
+AC_CANONICAL_HOST
+AC_CANONICAL_TARGET
+
AM_INIT_AUTOMAKE(libvorbis,1.0.1)
AM_MAINTAINER_MODE
@@ -67,8 +71,6 @@ dnl --------------------------------------------------
dnl Set build flags based on environment
dnl --------------------------------------------------
-AC_CANONICAL_HOST
-
dnl Set some target options
cflags_save="$CFLAGS"
@@ -182,12 +184,14 @@ dnl --------------------------------------------------
dnl Check for libraries
dnl --------------------------------------------------
-AC_CHECK_LIB(m, cos, LIBS="-lm", LIBS="")
+AC_CHECK_LIB(m, cos, VORBIS_LIBS="-lm", VORBIS_LIBS="")
AC_CHECK_LIB(pthread, pthread_create, pthread_lib="-lpthread", :)
XIPH_PATH_OGG(, AC_MSG_ERROR(must have Ogg installed!))
-LIBS="$LIBS $OGG_LIBS"
+libs_save=$LIBS
+LIBS="$OGG_LIBS $VORBIS_LIBS"
AC_CHECK_FUNC(oggpack_writealign, , AC_MSG_ERROR(Ogg >= 1.0 required !))
+LIBS=$libs_save
dnl --------------------------------------------------
dnl Check for library functions
@@ -200,9 +204,26 @@ dnl --------------------------------------------------
dnl Do substitutions
dnl --------------------------------------------------
-AC_SUBST(LIBS)
+AC_SUBST(VORBIS_LIBS)
AC_SUBST(DEBUG)
AC_SUBST(PROFILE)
AC_SUBST(pthread_lib)
-AC_OUTPUT(Makefile lib/Makefile lib/modes/Makefile lib/books/Makefile lib/books/coupled/Makefile lib/books/uncoupled/Makefile lib/books/floor/Makefile doc/Makefile doc/vorbisfile/Makefile doc/vorbisenc/Makefile include/Makefile include/vorbis/Makefile examples/Makefile win32/Makefile debian/Makefile vq/Makefile vorbis.pc vorbisenc.pc vorbisfile.pc)
+AC_OUTPUT([
+Makefile
+lib/Makefile
+lib/modes/Makefile
+lib/books/Makefile
+lib/books/coupled/Makefile
+lib/books/uncoupled/Makefile
+lib/books/floor/Makefile
+doc/Makefile doc/vorbisfile/Makefile doc/vorbisenc/Makefile
+include/Makefile include/vorbis/Makefile
+examples/Makefile
+win32/Makefile
+debian/Makefile
+vq/Makefile
+vorbis.pc
+vorbisenc.pc
+vorbisfile.pc
+])