summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am41
1 files changed, 22 insertions, 19 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index a98c4d83..3f142479 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -27,6 +27,22 @@ static_docs = \
vorbis-fidelity.html
# bits needed by the spec
+SPEC_TEX = \
+ Vorbis_I_spec.tex \
+ 01-introduction.tex \
+ 02-bitpacking.tex \
+ 03-codebook.tex \
+ 04-codec.tex \
+ 05-comment.tex \
+ 06-floor0.tex \
+ 07-floor1.tex \
+ 08-residue.tex \
+ 09-helper.tex \
+ 10-tables.tex \
+ a1-encapsulation-ogg.tex \
+ a2-encapsulation-rtp.tex \
+ footer.tex
+
SPEC_PNG = \
components.png \
floor1-1.png \
@@ -38,7 +54,10 @@ SPEC_PNG = \
residue-pack.png \
residue2.png \
window1.png \
- window2.png \
+ window2.png
+
+# Figure images generated by htlatex
+built_SPEC_PNG = \
Vorbis_I_spec0x.png \
Vorbis_I_spec1x.png \
Vorbis_I_spec2x.png \
@@ -55,23 +74,9 @@ SPEC_PNG = \
Vorbis_I_spec13x.png \
Vorbis_I_spec14x.png
-SPEC_TEX = \
- Vorbis_I_spec.tex \
- 01-introduction.tex \
- 02-bitpacking.tex \
- 03-codebook.tex \
- 04-codec.tex \
- 05-comment.tex \
- 06-floor0.tex \
- 07-floor1.tex \
- 08-residue.tex \
- 09-helper.tex \
- 10-tables.tex \
- a1-encapsulation-ogg.tex \
- a2-encapsulation-rtp.tex \
- footer.tex
-built_docs = Vorbis_I_spec.pdf Vorbis_I_spec.html Vorbis_I_spec.css
+built_docs = Vorbis_I_spec.pdf \
+ Vorbis_I_spec.html Vorbis_I_spec.css $(built_SPEC_PNG)
# conditionally make the generated documentation
if BUILD_DOCS
@@ -93,8 +98,6 @@ CLEANFILES = $(SPEC_TEX:%.tex=%.aux) \
Vorbis_I_spec.toc Vorbis_I_spec.xref \
Vorbis_I_spec.out.ps \
zzVorbis_I_spec.ps
-DISTCLEANFILES = $(built_docs)
-
# explicit rules for generating docs
if BUILD_DOCS