summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLorry <lorry@roadtrain.codethink.co.uk>2012-07-23 15:34:06 +0100
committerLorry <lorry@roadtrain.codethink.co.uk>2012-07-23 15:34:06 +0100
commit13c184b933d24b87ff574bc45eec430000fc5c76 (patch)
treef3efd0abe252130b8e41b3b423823e5bd0414f79 /Makefile.am
downloadlibvorbis-13c184b933d24b87ff574bc45eec430000fc5c76.tar.gz
Tarball conversion
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..e05d521
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,46 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = 1.7 foreign dist-zip dist-bzip2
+AUTOMAKE_OPTIONS = foreign 1.11 dist-zip dist-xz
+
+SUBDIRS = m4 include vq lib test doc
+
+if BUILD_EXAMPLES
+SUBDIRS += examples
+endif
+
+m4datadir = $(datadir)/aclocal
+m4data_DATA = vorbis.m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = vorbis.pc vorbisenc.pc vorbisfile.pc
+
+EXTRA_DIST = \
+ CHANGES COPYING \
+ todo.txt autogen.sh \
+ libvorbis.spec libvorbis.spec.in \
+ vorbis.m4 \
+ vorbis.pc.in vorbisenc.pc.in vorbisfile.pc.in \
+ vorbis-uninstalled.pc.in \
+ vorbisenc-uninstalled.pc.in \
+ vorbisfile-uninstalled.pc.in \
+ symbian \
+ macos macosx win32
+
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-docs
+
+dist-hook:
+ for item in $(EXTRA_DIST); do \
+ if test -d $$item; then \
+ echo -n "cleaning $$item dir for distribution..."; \
+ rm -rf `find $(distdir)/$$item -name .svn`; \
+ echo "OK"; \
+ fi; \
+ done
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"