summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2019-05-01 14:05:44 +0200
committerMarco Trevisan <mail@3v1n0.net>2019-08-12 15:14:37 +0000
commit0d9ff7db63af568feef8e8c566e249058ccfcb4e (patch)
treea70e3c631de6a5013fce23f329446649a91090ba /meson.build
parent0ceae2509eb6b04310533801ae599338939add89 (diff)
downloadlibwnck-0d9ff7db63af568feef8e8c566e249058ccfcb4e.tar.gz
meson: Fix -Dstartup_notification=enabled/disabled
'enabled' made the dependency required but did not set HAVE_STARTUP_NOTIFICATION. 'disabled' behaved the same as 'auto'. We are not allowed to compare booleans and feature option values, so just add everything to the configuration. Fixes https://gitlab.gnome.org/GNOME/libwnck/issues/139
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6e35c00..28799d8 100644
--- a/meson.build
+++ b/meson.build
@@ -43,7 +43,7 @@ pkg_deps = [
{'name': 'glib-2.0', 'version': '>= 2.32' },
{'name': 'gobject-2.0', 'version': '>= 2.13.0' },
{'name': 'gtk+-3.0', 'version': '>= 3.22.0' },
- {'name': STARTUP_NOTIFICATION_PACKAGE, 'version': '>= 0.4', 'required': get_option('startup_notification').enabled() },
+ {'name': STARTUP_NOTIFICATION_PACKAGE, 'version': '>= 0.4', 'required': get_option('startup_notification')},
{'name': X11_PACKAGE },
{'name': XRES_PACKAGE, 'required': false},
]
@@ -54,7 +54,7 @@ foreach p: pkg_deps
dep = dependency(pkg, version: p.get('version', []), required: required)
LIBWNCK_DEPS += dep
- if not required and dep.found()
+ if dep.found()
conf.set('HAVE_' + pkg.to_upper().underscorify(), 1)
endif
endforeach