summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2022-09-06 17:33:38 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2022-09-06 19:33:32 +0200
commit5ff3baf0dc814e7bc2f4209844d7da764bfd5f46 (patch)
tree1830aeb5371db7656963cae983e1d08cda4fc042 /CMakeLists.txt
parente86ede09d4593f73b00231f62a7dae7105a35ce9 (diff)
downloadlibxml2-5ff3baf0dc814e7bc2f4209844d7da764bfd5f46.tar.gz
python: Create .pyd on Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ac71dfa..b16af1f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -546,6 +546,9 @@ if(LIBXML2_WITH_PYTHON)
PREFIX lib
VERSION ${PROJECT_VERSION}
)
+ if (WIN32)
+ set_target_properties(LibXml2Mod PROPERTIES SUFFIX ".pyd")
+ endif()
install(
TARGETS LibXml2Mod
ARCHIVE DESTINATION ${LIBXML2_PYTHON_INSTALL_DIR} COMPONENT development