summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2003-02-05 13:19:53 +0000
committerDaniel Veillard <veillard@src.gnome.org>2003-02-05 13:19:53 +0000
commit71531f33450f9a809eab050104e55c84b77b2a9e (patch)
tree8c469e513e2e72b999e9a64a9f5177b8ace88c4b /Makefile.am
parentec498e1b33ffef0246296491642facb95b77a743 (diff)
downloadlibxml2-71531f33450f9a809eab050104e55c84b77b2a9e.tar.gz
comments cleanups use xmllint for doing the RelaxNG tests preparing 2.5.2
* HTMLparser.c tree.c xmlIO.c: comments cleanups * Makefile.am: use xmllint for doing the RelaxNG tests * configure.in: preparing 2.5.2 made schemas support default to on instead of off * relaxng.c: removed the verbosity * xmllint.c: added --relaxng option * python/generator.py python/libxml_wrap.h: prepared the integration of the new RelaxNG module and schemas * result/relaxng/*: less verbose output Daniel
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 00bd1cec..862cdfc4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -686,7 +686,7 @@ Schemastests: testSchemas$(EXEEXT)
fi ; \
done; done)
-Relaxtests: testRelax$(EXEEXT)
+Relaxtests: xmllint$(EXEEXT)
@(echo > .memdump)
@echo "##"
@echo "## Relax-NG regression tests"
@@ -699,12 +699,12 @@ Relaxtests: testRelax$(EXEEXT)
if [ ! -f $(srcdir)/result/relaxng/"$$name"_"$$xno" ]; \
then \
echo New test file "$$name"_"$$xno" ; \
- $(CHECKER) $(top_builddir)/testRelax $$i $$j \
+ $(CHECKER) $(top_builddir)/xmllint$(EXEEXT) --noout --relaxng $$i $$j \
> $(srcdir)/result/relaxng/"$$name"_"$$xno" \
2> $(srcdir)/result/relaxng/"$$name"_"$$xno".err; \
else \
echo Testing "$$name"_"$$xno" ; \
- $(CHECKER) $(top_builddir)/testRelax $$i $$j \
+ $(CHECKER) $(top_builddir)/xmllint$(EXEEXT) --noout --relaxng $$i $$j \
> res.$$name 2> err.$$name;\
grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0";\
diff $(srcdir)/result/relaxng/"$$name"_"$$xno" \