summaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2022-04-03 01:42:17 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2022-04-03 14:08:43 +0200
commit7016b0e0999156cd1ad96029763351cb6391988b (patch)
tree0931152c3728048e9941a3aa35b51d840a2b9ead /example/Makefile.am
parent6d10df7c5c6a098078db8a7649d5d9a1f820d9cd (diff)
downloadlibxml2-7016b0e0999156cd1ad96029763351cb6391988b.tar.gz
Don't overlink executables
With very few exceptions, utilities and test programs don't require any external libraries. - xmllint and xmlcatalog need libreadline - runtest and testThreads need pthreads
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
index 5839bd0f..21130b9a 100644
--- a/example/Makefile.am
+++ b/example/Makefile.am
@@ -1,7 +1,6 @@
check_PROGRAMS = gjobread
-AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(srcdir)/include
-AM_CFLAGS = $(THREAD_CFLAGS) $(Z_CFLAGS)
-LDADD = $(RDL_LIBS) $(top_builddir)/libxml2.la $(THREAD_LIBS) $(Z_LIBS) $(ICONV_LIBS) -lm $(WIN32_EXTRA_LIBADD)
+AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include
+LDADD = $(top_builddir)/libxml2.la
gjobread_SOURCES=gjobread.c