summaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2004-06-27 12:08:10 +0000
committerDaniel Veillard <veillard@src.gnome.org>2004-06-27 12:08:10 +0000
commita2351322c89608d09ce1a99e5eccd62d00c79890 (patch)
tree231ae94386ad9bf77dcaf8fe6bfbeca47ca63132 /example/Makefile.am
parent3403adde326013574de71ff667c6d75d8d62656b (diff)
downloadlibxml2-a2351322c89608d09ce1a99e5eccd62d00c79890.tar.gz
hack based on Arjan van de Ven suggestion to reduce ELF footprint and
* elfgcchack.h doc/elfgcchack.xsl libxml.h: hack based on Arjan van de Ven suggestion to reduce ELF footprint and generated code. Based on aliasing of libraries function to generate direct call instead of indirect ones * doc/libxml2-api.xml doc/Makefile.am doc/apibuild.py: added automatic generation of elfgcchack.h based on the API description, extended the API description to show the conditionals configuration flags required for symbols. * nanohttp.c parser.c xmlsave.c include/libxml/*.h: lot of cleanup * doc/*: regenerated the docs. Daniel
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
index 0138775d..9eb6a76d 100644
--- a/example/Makefile.am
+++ b/example/Makefile.am
@@ -1,10 +1,10 @@
noinst_PROGRAMS = gjobread
-INCLUDES = \
- -I$(top_builddir) -I$(top_srcdir) \
- -I$(top_builddir)/include \
- -I$(top_srcdir)/include -I@srcdir@
-
-LDADD = $(top_builddir)/libxml2.la @THREAD_LIBS@ @Z_LIBS@ $(ICONV_LIBS) -lm @WIN32_EXTRA_LIBADD@
-
-
+INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I@srcdir@/include @THREAD_CFLAGS@ @Z_CFLAGS@
+DEPS = $(top_builddir)/libxml2.la
+LDADDS = @STATIC_BINARIES@ $(top_builddir)/libxml2.la @THREAD_LIBS@ @Z_LIBS@ $(ICONV_LIBS) -lm @WIN32_EXTRA_LIBADD@
+
+gjobread_SOURCES=gjobread.c
+gjobread_LDFLAGS=
+gjobread_DEPENDENCIES= $(DEPS)
+gjobread_LDADD= @RDL_LIBS@ $(LDADDS)