summaryrefslogtreecommitdiff
path: root/xstc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xstc/Makefile.am')
-rw-r--r--xstc/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/xstc/Makefile.am b/xstc/Makefile.am
index 45309ff0..82de1ef6 100644
--- a/xstc/Makefile.am
+++ b/xstc/Makefile.am
@@ -64,18 +64,24 @@ $(TESTDIRS):
pytests: $(PYSCRIPTS) $(TESTDIRS)
-@(if [ -x nist-test.py -a -d nisttest ] ; then \
echo "## Running NIST Schemas tests"; \
- PYTHONPATH="$$PYTHONPATH:../python:../python/.libs:..:../libs" ;\
+ PYTHONPATH="../python:../python/.libs:..:../libs:$$PYTHONPATH" ;\
export PYTHONPATH; \
+ LD_LIBRARY_PATH="$(top_builddir)/.libs:$$LD_LIBRARY_PATH" ; \
+ export LD_LIBRARY_PATH; \
$(CHECKER) $(PYTHON) nist-test.py -s -b $(srcdir) ; fi)
-@(if [ -x sun-test.py -a -d suntest ] ; then \
echo "## Running Sun Schemas tests"; \
- PYTHONPATH="$$PYTHONPATH:../python:../python/.libs:..:../libs" ;\
+ PYTHONPATH="../python:../python/.libs:..:../libs:$$PYTHONPATH" ;\
export PYTHONPATH; \
+ LD_LIBRARY_PATH="$(top_builddir)/.libs:$$LD_LIBRARY_PATH" ; \
+ export LD_LIBRARY_PATH; \
$(CHECKER) $(PYTHON) sun-test.py -s -b $(srcdir) ; fi)
-@(if [ -x ms-test.py -a -d msxsdtest ] ; then \
echo "## Running Microsoft Schemas tests"; \
- PYTHONPATH="$$PYTHONPATH:../python:../python/.libs:..:../libs" ;\
+ PYTHONPATH="../python:../python/.libs:..:../libs:$$PYTHONPATH" ;\
export PYTHONPATH; \
+ LD_LIBRARY_PATH="$(top_builddir)/.libs:$$LD_LIBRARY_PATH" ; \
+ export LD_LIBRARY_PATH; \
$(CHECKER) $(PYTHON) ms-test.py -s -b $(srcdir) ; fi)
tests: