summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarkus Rickert <rickert@fortiss.org>2020-06-04 21:09:57 +0200
committerMarkus Rickert <rickert@fortiss.org>2020-07-12 18:40:14 +0200
commita59b1d823cb76ad70e56feaed77b3a7f28350734 (patch)
treed93bd8b831bba80da126f99b83e2853c00850572 /CMakeLists.txt
parentea1c27fca299f4f29d8bd1e29ac2ad21aea81bcc (diff)
downloadlibxslt-a59b1d823cb76ad70e56feaed77b3a7f28350734.tar.gz
Set working directory for Python generator
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7599c0ae..fabc669f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -397,6 +397,8 @@ if(LIBXSLT_WITH_PYTHON)
${CMAKE_CURRENT_SOURCE_DIR}/python/generator.py
${CMAKE_CURRENT_SOURCE_DIR}/doc/libxslt-api.xml
${CMAKE_CURRENT_SOURCE_DIR}/python/libxslt-python-api.xml
+ WORKING_DIRECTORY
+ ${CMAKE_CURRENT_BINARY_DIR}
)
unset(ENV{SRCDIR})
file(READ python/libxsl.py LIBXSL_PY)