summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHugh McMaster <hugh.mcmaster@outlook.com>2019-07-29 21:45:32 +1000
committerHugh McMaster <hugh.mcmaster@outlook.com>2019-07-29 21:52:41 +1000
commitcc1b0b4b686c371059cec2b90a8a7aa7cd16c873 (patch)
treee8d4a9d5355203dc8e6180cf8ed7c31d6af2dc1d /Makefile.am
parentb0c4b62ed386f4962988fb0bef79153213ba5174 (diff)
downloadlibxslt-cc1b0b4b686c371059cec2b90a8a7aa7cd16c873.tar.gz
xslt-config.in: Add a --dynamic option to --libs
xslt-config --libs prints static library linking information by default. This is un-necessary for most programs, so introduce a new option, --dynamic, which, when combined with --libs, only prints shared library linking information.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ff10f574..2c417d0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,6 +38,7 @@ xsltConf.sh: xsltConf.sh.in Makefile
-e 's?\@XSLT_INCLUDEDIR\@?$(XSLT_INCLUDEDIR)?g' \
-e 's?\@VERSION\@?$(VERSION)?g' \
-e 's?\@XSLT_LIBS\@?$(XSLT_LIBS) $(EXTRA_LIBS)?g' \
+ -e 's?\@XSLT_PRIVATE_LIBS\@?$(XSLT_PRIVATE_LIBS)?g' \
< $(srcdir)/xsltConf.sh.in > xsltConf.tmp \
&& mv xsltConf.tmp xsltConf.sh