summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKirill Simonov <xi@resolvent.net>2014-01-12 18:27:39 -0600
committerKirill Simonov <xi@resolvent.net>2014-01-12 18:27:39 -0600
commit01e8dadf4c67ec14e16057d725caee991414a502 (patch)
tree6f2826892d733016914b987c74459b8c299b922a /CMakeLists.txt
parentf54fc409222be8b5bd52850d9ec141dfc06bfc05 (diff)
downloadlibyaml-git-01e8dadf4c67ec14e16057d725caee991414a502.tar.gz
Added a basic CMake project.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d30c536
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Minimal CMake project for building a static library under Windows.
+
+cmake_minimum_required (VERSION 2.8)
+project (yaml C)
+
+set (YAML_VERSION_MAJOR 0)
+set (YAML_VERSION_MINOR 1)
+set (YAML_VERSION_PATCH 4)
+set (YAML_VERSION_STRING "${YAML_VERSION_MAJOR}.${YAML_VERSION_MINOR}.${YAML_VERSION_PATCH}")
+
+file (GLOB SRC src/*.c)
+
+include_directories (include win32)
+add_definitions (-DHAVE_CONFIG_H -DYAML_DECLARE_STATIC)
+add_library (yaml STATIC ${SRC})
+