summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiguel Grinberg <miguel.grinberg@gmail.com>2016-12-05 18:39:37 -0800
committerMiguel Grinberg <miguel.grinberg@gmail.com>2016-12-05 20:59:20 -0800
commit6dfd50f13f18be0d381d2bcd2f9cebb71d7c7615 (patch)
tree7a629438612e793045a924f8d0dd9c46c237fe50 /CMakeLists.txt
parente4fd0393e6e97439666527db71c1fa18482778a7 (diff)
downloadlibyaml-git-6dfd50f13f18be0d381d2bcd2f9cebb71d7c7615.tar.gz
add unit tests to cmake and appveyor config
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9bfe761..40db882 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,3 +14,12 @@ include_directories (include win32)
add_definitions (-DHAVE_CONFIG_H -DYAML_DECLARE_STATIC)
add_library (yaml STATIC ${SRC})
+add_executable (test-version tests/test-version.c)
+target_link_libraries(test-version yaml)
+add_test(NAME version COMMAND test-version)
+
+add_executable (test-reader tests/test-reader.c)
+target_link_libraries(test-reader yaml)
+add_test(NAME reader COMMAND test-reader)
+
+enable_testing()