summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTina Müller (tinita) <cpan2@tinita.de>2020-04-19 12:36:01 +0200
committerGitHub <noreply@github.com>2020-04-19 12:36:01 +0200
commit47bf3f086fbea5c02b30f99dcf2e56984af1a641 (patch)
tree484e9a3bc288cd3e6843fbd456b26edf763b45c0 /Makefile.am
parentbf5290289996338dcba9471b839013068d9e9ae8 (diff)
downloadlibyaml-git-47bf3f086fbea5c02b30f99dcf2e56984af1a641.tar.gz
Add packaging/docker-dist to Makefile.am (#143)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b21549a..fc7bc2e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,7 @@ maintainer-clean-local:
-find ${builddir} -name Makefile.in -exec rm -f '{}' ';'
distclean-local:
- rm -fr tests/run-test-suite
+ rm -fr tests/run-test-suite packaging
-git worktree prune
.PHONY: bootstrap
@@ -34,3 +34,13 @@ tests/run-test-suite:
-git branch --track run-test-suite origin/run-test-suite
-git worktree prune
git worktree add $@ run-test-suite
+
+packaging:
+ git branch --track $@ origin/$@
+ git worktree add --force $@ $@
+
+docker-dist: packaging
+ make -C $</docker libyaml-dist
+
+docker-test-pyyaml: packaging
+ make -C $</docker test-pyyaml