summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIngy döt Net <ingy@ingy.net>2016-12-29 20:14:14 -0600
committerIngy döt Net <ingy@ingy.net>2016-12-30 11:09:58 -0600
commita672b0710919287ffbede8594c47aade35dd5874 (patch)
treee5a113d926cdd6cdc112066ee94e11c261191461 /Makefile.am
parent52b6634fb39a09c71782caf50005f0f23d2cec95 (diff)
downloadlibyaml-git-a672b0710919287ffbede8594c47aade35dd5874.tar.gz
Include libyaml-test and libyaml-parser-emitter
Before the `make test-suite` command would clone yaml/libyaml-test which would in tuen clone yaml/libyaml-parser-emitter. Now they are part of the repository since they are not really useful outside the repository. They still clone the data branch of yaml/yaml-test-suite. That is where all the actual test data resides. That belongs outside the repo because it is intended for all yaml frameworks.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b47f33..6425b6b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,19 +13,18 @@ maintainer-clean-local:
-find ${builddir} -name Makefile.in -exec rm -f '{}' ';'
distclean-local:
- -rm -fr libyaml-test
+ -make -C tests/run-test-suite clean
.PHONY: bootstrap
bootstrap: maintainer-clean
./bootstrap
+ ./configure
+ make
test: all
make -C tests check-TESTS
-test-suite: libyaml-test
- (export LIBYAML_DIR=$$PWD; make -C $< test)
-
-libyaml-test:
- git clone https://github.com/yaml/$@
+test-suite:
+ (export LIBYAML_DIR=$$PWD; make -C tests/run-test-suite test)
test-all: test test-suite