summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTina Müller <cpan2@tinita.de>2020-05-29 23:07:16 +0200
committerIngy döt Net <ingy@ingy.net>2020-06-22 10:21:14 -0700
commitacd6f6f014c25e46363e718381e0b35205df2d83 (patch)
tree59c59fd0ed36780185320f9748ea3e6054887297 /Makefile.am
parent2c891fc7a770e8ba2fec34fc6b545c672beb37e6 (diff)
downloadlibyaml-git-acd6f6f014c25e46363e718381e0b35205df2d83.tar.gz
Add workflow for creating release tarballsrelease/test
Also minor cleanup of .github/workflows/main.yml
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 551c740..45d9c27 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@ maintainer-clean-local:
-find ${builddir} -name Makefile.in -exec rm -f '{}' ';'
distclean-local:
- rm -fr tests/run-test-suite packaging
+ rm -fr tests/run-test-suite
-git worktree prune
.PHONY: bootstrap
@@ -43,12 +43,9 @@ ifeq ($(LIBYAML_TEST_SUITE_RUN_REPO),$(LIBYAML_TEST_SUITE_RUN_REPO_DEFAULT))
git clone --branch $(LIBYAML_TEST_SUITE_RUN_BRANCH) $(LIBYAML_TEST_SUITE_RUN_REPO) $@
endif
-packaging:
- -git branch --track $@ origin/$@
- git worktree add --force $@ $@
+docker-build:
+ make -C pkg/docker build
-docker-dist: packaging
- make -C $</docker libyaml-dist
+docker-dist:
+ make -C pkg/docker libyaml-dist
-docker-test-pyyaml: packaging
- make -C $</docker test-pyyaml