summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIngy döt Net <ingy@ingy.net>2017-12-28 13:16:38 -0800
committerIngy döt Net <ingy@ingy.net>2017-12-29 19:58:07 -0800
commite4aee06ff401668404de21b4af4c6a90be0f35a6 (patch)
treeb77a6a93374db9cad922ea4194a28fecc179ded2 /Makefile.am
parent6a9e942e27f0ca53d26ab2b4c87249dd82014723 (diff)
downloadlibyaml-git-e4aee06ff401668404de21b4af4c6a90be0f35a6.tar.gz
Move tests/run-test-suite to branch run-test-suite
with the intent that `make test-suite` will use it as a branch. This commit makes the libyaml and yaml-test-suite repos completely independent. The only thing in master is a Makefile rule for `make run-test-suite`. The run-test-suite branch takes care of everything else. This will keep the master branch history clean from any yaml-test-suite activity, while keeping everything up to date. Pinning will just work for whatever commit of master you run the tests from. The pinning work will all be done in the `run-test-suite` branch.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c63b274..45ad78d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,8 @@ maintainer-clean-local:
-find ${builddir} -name Makefile.in -exec rm -f '{}' ';'
distclean-local:
- -make -C tests/run-test-suite clean
+ -rm -fr tests/run-test-suite
+ -git worktree prune
.PHONY: bootstrap
bootstrap: maintainer-clean
@@ -24,7 +25,11 @@ bootstrap: maintainer-clean
test: all
make -C tests check-TESTS
-test-suite:
- make -C tests/run-test-suite test
+test-suite: tests/run-test-suite
+ make -C $< test
test-all: test test-suite
+
+tests/run-test-suite:
+ git fetch origin run-test-suite:run-test-suite
+ git worktree add $@ run-test-suite