summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKirill Simonov <xi@resolvent.net>2006-05-20 22:43:15 +0000
committerKirill Simonov <xi@resolvent.net>2006-05-20 22:43:15 +0000
commitcec6fc98ebecc208edc30a900e6ab195e7c21851 (patch)
tree5d1010377ff93a7c476f89fcaa8847d83eb4d8ab /configure.ac
parent9e05b78ca5d1e05a5665da4d503eaad56eb49cb1 (diff)
downloadlibyaml-git-cec6fc98ebecc208edc30a900e6ab195e7c21851.tar.gz
Add the basic autoconf infrastructure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac70
1 files changed, 70 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..34d7f70
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,70 @@
+# Run `./bootstrap` to generate the "configure" script.
+
+# Define the package version numbers and the bug reporting link.
+m4_define([YAML_MAJOR], 0)
+m4_define([YAML_MINOR], 0)
+m4_define([YAML_PATCH], 1)
+m4_define([YAML_BUGS], [http://pyyaml.org/newticket?component=libyaml])
+
+# Define the libtool version numbers; check the Autobook, Section 11.4.
+# Bump the libtool version numbers using the following algorithm:
+# if (the current interface has not been changed):
+# YAML_REVISION += 1
+# else:
+# YAML_REVISION = 0
+# YAML_CURRENT += 1
+# if (this release is backward compatible with the previous release):
+# YAML_AGE += 1
+# else:
+# YAML_AGE = 0
+m4_define([YAML_RELEASE], 0)
+m4_define([YAML_CURRENT], 0)
+m4_define([YAML_REVISION], 0)
+m4_define([YAML_AGE], 0)
+
+# Initialize autoconf & automake.
+AC_PREREQ(2.59)
+AC_INIT([yaml], [YAML_MAJOR.YAML_MINOR.YAML_PATCH], [YAML_BUGS])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([1.9 foreign])
+
+# Define macro variables for the package version numbers.
+AC_DEFINE(YAML_VERSION_MAJOR, YAML_MAJOR, [Define the major version number.])
+AC_DEFINE(YAML_VERSION_MINOR, YAML_MINOR, [Define the minor version number.])
+AC_DEFINE(YAML_VERSION_PATCH, YAML_PATCH, [Define the patch version number.])
+AC_DEFINE(YAML_VERSION_STRING, "YAML_MAJOR.YAML_MINOR.YAML_PATCH", [Define the version string.])
+
+# Define substitutions for the libtool version numbers.
+YAML_LT_RELEASE=YAML_RELEASE
+YAML_LT_CURRENT=YAML_CURRENT
+YAML_LT_REVISION=YAML_REVISION
+YAML_LT_AGE=YAML_AGE
+AC_SUBST(YAML_LT_RELEASE)
+AC_SUBST(YAML_LT_CURRENT)
+AC_SUBST(YAML_LT_REVISION)
+AC_SUBST(YAML_LT_AGE)
+
+# Note: in order to update checks, run `autoscan` and look through "configure.scan".
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_LIBTOOL
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdlib.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+
+# Define Makefiles.
+AC_CONFIG_FILES([include/Makefile src/Makefile Makefile tests/Makefile])
+
+# Generate the "configure" script.
+AC_OUTPUT