summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 95f2faa..45fc485 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,8 @@ SUBDIRS = include src . tests
EXTRA_DIST = Changes ReadMe.md License CMakeLists.txt doc/doxygen.cfg
+LIBYAML_TEST_SUITE_RUN_BRANCH ?= run-test-suite
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = yaml-0.1.pc
@@ -31,9 +33,9 @@ test-suite: tests/run-test-suite all
test-all: test test-suite
tests/run-test-suite:
- -git branch --track run-test-suite origin/run-test-suite
+ -git branch --track $(LIBYAML_TEST_SUITE_RUN_BRANCH) origin/$(LIBYAML_TEST_SUITE_RUN_BRANCH)
-git worktree prune
- git worktree add $@ run-test-suite
+ git worktree add $@ $(LIBYAML_TEST_SUITE_RUN_BRANCH)
packaging:
-git branch --track $@ origin/$@