summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorxi <xi@18f92427-320e-0410-9341-c67f048884a3>2006-05-21 14:58:32 +0000
committerxi <xi@18f92427-320e-0410-9341-c67f048884a3>2006-05-21 14:58:32 +0000
commit9dacdb3dceebc1f1d11a9f2445b73745d7ea58b5 (patch)
tree6cb0f90ea5b674ef298fe24559856d575d55adb8 /Makefile.am
parent22b7d273c0cc7fff3e6149677a5a099c8ad97748 (diff)
downloadlibyaml-9dacdb3dceebc1f1d11a9f2445b73745d7ea58b5.tar.gz
Add doxygen support.
git-svn-id: http://svn.pyyaml.org/libyaml/trunk@172 18f92427-320e-0410-9341-c67f048884a3
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d25f6d2..d1c309f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,3 +2,14 @@
## the "$SUBDIR" subdirectories.
SUBDIRS = include src . tests
+
+EXTRA_DIST = doc/doxygen.cfg
+
+maintainer-clean-local:
+ -rm -f aclocal.m4 config.h.in configure config/*
+ -find ${builddir} -name Makefile.in -exec rm -f '{}' ';'
+
+.PHONY: bootstrap
+bootstrap: maintainer-clean
+ ./bootstrap
+