summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2015-09-07 16:28:48 +1200
committerRobert Ancell <robert.ancell@canonical.com>2015-09-07 16:28:48 +1200
commit5033cab2f56d5ee1ea9f789f6fe59dd99b7d6e12 (patch)
treebd67358c68d8091ddc5764c8bb8a3d8b1d805309 /configure.ac
parent450ddaa2abfdaa9e5b02b64d8818303ff7400ed4 (diff)
parent8fe51939ad74f86f7d2e7256d01cb46bd6e5b403 (diff)
downloadlightdm-git-5033cab2f56d5ee1ea9f789f6fe59dd99b7d6e12.tar.gz
Use libaudit to generate audit events
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a85846aa..27a0e096 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,6 +129,23 @@ if test x"$enable_liblightdm_qt5" != "xno"; then
fi
AM_CONDITIONAL(COMPILE_LIBLIGHTDM_QT5, test x"$compile_liblightdm_qt5" != "xno")
+AC_ARG_ENABLE([audit],
+ AS_HELP_STRING([--enable-audit],
+ [Enable audit logging of login and logout events [[default=auto]]]),
+ [enable_audit=$enableval],
+ [enable_audit=auto])
+if test x"$enable_audit" != "xno"; then
+ AC_CHECK_LIB([audit], [audit_log_user_message],
+ [AC_DEFINE(HAVE_LIBAUDIT, 1, [libaudit support])
+ LIGHTDM_LIBS="${LIGHTDM_LIBS} -laudit"
+ ],
+ [if test "x$enable_audit" != xauto; then
+ AC_MSG_FAILURE(
+ [--enable-audit was given, but test for libaudit failed])
+ fi
+ ])
+fi
+
AC_MSG_CHECKING(whether to build tests)
AC_ARG_ENABLE(tests,
AS_HELP_STRING([--disable-tests], [Disable tests building]),