summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2014-04-26 19:07:03 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2014-04-26 19:07:03 +0200
commit169c95268be23a3f5b057c357d79299f600b0e93 (patch)
tree27eed1dbdddb2b7cfa34cedfbaf7cbb23d20d193 /debian/rules
parent695964bb9c1a92f1e3a78c5850451abcc8900b63 (diff)
downloadlightdm-git-169c95268be23a3f5b057c357d79299f600b0e93.tar.gz
Add systemd integration
- Add systemd unit. - Set /etc/systemd/system/display-manager.service symlink according to /etc/X11/default-display-manager. - Build-depend on and enable dh-systemd.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 0e141f94..d0651d04 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
LDFLAGS+=-Wl,--as-needed
%:
- dh $@ --with quilt,autoreconf,translations --parallel
+ dh $@ --with quilt,autoreconf,translations,systemd --parallel
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
@@ -27,6 +27,9 @@ override_dh_install:
override_dh_installinit:
dh_installinit --no-start
+override_dh_systemd_start:
+ dh_systemd_start -plightdm --no-start -r lightdm.service
+
override_dh_installpam:
dh_installpam
dh_installpam --name=lightdm-autologin