summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRichard Hansen <rhansen@rhansen.org>2023-04-16 23:19:27 -0400
committerRobert Ancell <robert.ancell@gmail.com>2023-04-28 13:34:51 +1200
commitdcd37d9548049a9764a4286dd238f6731826e8ee (patch)
tree63fce3712cde93fdb4f6fc5472d04c045b7a47e3 /tests/Makefile.am
parent6a5bca08577e4bbba486f09df2cfbd8080643d39 (diff)
downloadlightdm-git-dcd37d9548049a9764a4286dd238f6731826e8ee.tar.gz
Initialize WaylandSessionPrivate.vt to -1
This matters when starting a Wayland session on a non-seat0 seat: * It eliminates an erroneous attempt to switch to VT 0. * The XDG_VTNR environment variable is no longer set. Also add a multiseat test. A similar change for XServerLocalPrivate is not needed because its vt field is already initialized to -1.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1002c834..734f6482 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -246,6 +246,7 @@ TESTS = \
test-multi-seat-change-graphical \
test-multi-seat-change-graphical-disabled \
test-multi-seat-globbing-config-sections \
+ test-multi-seat-wayland \
test-mir-autologin \
test-mir-greeter \
test-mir-session \
@@ -480,6 +481,7 @@ EXTRA_DIST = \
scripts/multi-seat-seat0-non-graphical.conf \
scripts/multi-seat-seat0-non-graphical-disabled.conf \
scripts/multi-seat-globbing-config-sections.conf \
+ scripts/multi-seat-wayland.conf \
scripts/no-accounts-service.conf \
scripts/no-config.conf \
scripts/no-console-kit.conf \