summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRichard Hansen <rhansen@rhansen.org>2023-04-17 04:33:07 -0400
committerRobert Ancell <robert.ancell@gmail.com>2023-04-28 13:34:51 +1200
commite520b32f9c4ab67b704874341f95925980349eab (patch)
tree5d02787d3a1e6c7871a443635c017906ff63f976 /tests/Makefile.am
parentc84feb03279e7b1993e5307d4542e02bd5475629 (diff)
downloadlightdm-git-e520b32f9c4ab67b704874341f95925980349eab.tar.gz
Disable user switching if logind says it isn't supported
This should work now that seat_local_get_active_session returns the proper value for non-seat0 seats. Note: systemd-logind v245 and older erroneously report CanMultiSession=no on non-seat0 seats even when it is supported. This change will break those users. See <https://github.com/systemd/systemd/pull/15337>.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 734f6482..98a3acce 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -241,6 +241,7 @@ TESTS = \
test-multi-seat-autologin-seat1 \
test-multi-seat-seat0-non-graphical \
test-multi-seat-seat0-non-graphical-disabled \
+ test-multi-seat-no-multi-session \
test-multi-seat-non-graphical \
test-multi-seat-non-graphical-disabled \
test-multi-seat-change-graphical \
@@ -476,6 +477,7 @@ EXTRA_DIST = \
scripts/multi-seat-change-graphical.conf \
scripts/multi-seat-change-graphical-disabled.conf \
scripts/multi-seat-login.conf \
+ scripts/multi-seat-no-multi-session \
scripts/multi-seat-non-graphical.conf \
scripts/multi-seat-non-graphical-disabled.conf \
scripts/multi-seat-seat0-non-graphical.conf \