summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew P. <pan.pav.7c5@gmail.com>2014-01-29 22:08:35 +0300
committerAndrew P. <pan.pav.7c5@gmail.com>2014-01-29 22:08:35 +0300
commit5b7b83ad19e43735624c347ec544493a318acbf6 (patch)
tree57f1b96f7b44daf534b4149d808862ba79924a4b /configure.ac
parentf4be1c9361d5ddcb1c24163d2f3c9e178643fc89 (diff)
downloadlightdm-gtk-greeter-git-5b7b83ad19e43735624c347ec544493a318acbf6.tar.gz
Indicators update
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 35 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 60c0adc..d7132c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,7 +41,10 @@ INDICATOR_REQUIRED_VERSION=0.3.92
AS_IF([test "x$have_gtk2" = "xyes"],
[INDICATOR_PKG=indicator-0.4],
- [INDICATOR_PKG=indicator3-0.4])
+ [
+ INDICATOR_PKG=indicator3-0.4
+ IDO_PKG=libido3-0.1
+ ])
AC_ARG_ENABLE([libindicator],
AC_HELP_STRING([--enable-libindicator], [Enable libindicator support])
@@ -51,8 +54,11 @@ AC_ARG_ENABLE([libindicator],
AS_IF([test "x$enable_libindicator" = "xyes"], [
AS_IF([$PKG_CONFIG --exists "$INDICATOR_PKG >= $INDICATOR_REQUIRED_VERSION" >/dev/null 2>&1], [
PKG_CHECK_MODULES([LIBINDICATOR], [$INDICATOR_PKG >= $INDICATOR_REQUIRED_VERSION], [
+ have_libindicator=yes
INDICATORDIR=`$PKG_CONFIG --variable=indicatordir $INDICATOR_PKG`
AC_SUBST(INDICATORDIR)
+ UNITY_INDICATORDIR="${prefix}/share/unity/indicators"
+ AC_SUBST(UNITY_INDICATORDIR)
AC_DEFINE([HAVE_LIBINDICATOR], [1], [Define if "$INDICATOR_PKG" is present])
])
], [
@@ -64,6 +70,34 @@ AS_IF([test "x$enable_libindicator" = "xyes"], [
AC_MSG_RESULT([disabled])
])
+AC_ARG_ENABLE([libido],
+ AC_HELP_STRING([--enable-libido], [Enable libido support])
+ AC_HELP_STRING([--disable-libido], [Disable libido support]),
+ [], [enable_libido=yes])
+
+AS_IF([test "x$enable_libido" = "xyes" && test "x$have_libindicator" = "xyes"], [
+ AS_IF([$PKG_CONFIG --exists "$IDO_PKG" >/dev/null 2>&1], [
+ PKG_CHECK_MODULES([LIBIDO], [$IDO_PKG], [
+ AC_DEFINE([HAVE_LIBIDO], [1], [Define if "$IDO_PKG" is present])
+ ])
+ ], [
+ AC_MSG_CHECKING([for optional package $IDO_PKG])
+ AC_MSG_RESULT([not found])
+ ])
+], [
+ AC_MSG_CHECKING([for optional package $IDO_PKG])
+ AC_MSG_RESULT([disabled])
+])
+
+AC_ARG_ENABLE([indicator-services],
+ AC_HELP_STRING([--enable-indicator-services], [Try to start indicator services])
+ AC_HELP_STRING([--disable-indicator-services], [Do not start indicator services]),
+ [], [enable_indicator_services=no])
+
+AS_IF([test "x$enable_indicator_services" != "xno" && test "x$have_libindicator" = "xyes"], [
+ AC_DEFINE([START_INDICATOR_SERVICES], [], [Try to start indicator-services])
+])
+
dnl ###########################################################################
dnl Internationalization
dnl ###########################################################################