summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2011-11-29 14:06:00 +1100
committerRobert Ancell <robert.ancell@canonical.com>2011-11-29 14:06:00 +1100
commit23b165b78ce4a03d20183edf48f6220a363064b9 (patch)
treebba7363616a3d976cd5c1a011a4e9c1fbbbea1d1 /src/Makefile.am
downloadlightdm-gtk-greeter-git-23b165b78ce4a03d20183edf48f6220a363064b9.tar.gz
Split lightdm-gtk-greeter out of lightdm
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..e684dcc
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,18 @@
+sbin_PROGRAMS = lightdm-gtk-greeter
+
+lightdm_gtk_greeter_SOURCES = \
+ lightdm-gtk-greeter.c
+
+lightdm_gtk_greeter_CFLAGS = \
+ -DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
+ -DLOCALEDIR=\""$(localedir)"\" \
+ -DGREETER_DATA_DIR=\""$(greeterdatadir)"\" \
+ -DCONFIG_FILE=\""$(configdir)/lightdm-gtk-greeter.conf"\" \
+ $(GREETER_CFLAGS) \
+ $(WARN_CFLAGS)
+
+lightdm_gtk_greeter_LDADD = \
+ $(GREETER_LIBS)
+
+DISTCLEANFILES = \
+ Makefile.in