summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Bühler <stbuehler@web.de>2008-12-05 22:30:32 +0000
committerStefan Bühler <stbuehler@web.de>2008-12-05 22:30:32 +0000
commit454aefc51a3a522594018bd05f465c3bc692a0b2 (patch)
tree1a3c9deaaf7e8f2cd325c093ae2c516276daf25c /CMakeLists.txt
parent34172dfb09fb290dbbabefe44be19aba1174c5a5 (diff)
downloadlighttpd-git-454aefc51a3a522594018bd05f465c3bc692a0b2.tar.gz
[cmake] Add basic cmake support
- Not distributed yet (so only available in svn checkout) git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@2359 152afb58-edef-0310-8abb-c4023f1b3aa9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..56fbbbfb
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,26 @@
+PROJECT(lighttpd C)
+
+CMAKE_MINIMUM_REQUIRED(VERSION 2.4.0 FATAL_ERROR)
+
+SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
+
+INCLUDE(CTest)
+
+ENABLE_TESTING()
+
+SET(CPACK_PACKAGE_VERSION_MAJOR 2)
+SET(CPACK_PACKAGE_VERSION_MINOR 0)
+SET(CPACK_PACKAGE_VERSION_PATCH 0)
+
+SET(CPACK_RESOURCE_FILE_LICENSE "${CMAKE_SOURCE_DIR}/COPYING")
+SET(CPACK_RESOURCE_FILE_README "${CMAKE_SOURCE_DIR}/README")
+SET(CPACK_PACKAGE_VENDOR "jan@kneschke.de")
+
+SET(CPACK_SOURCE_GENERATOR "TGZ")
+SET(CPACK_SOURCE_IGNORE_FILES "/\\\\.;~$;/_;build/;CMakeFiles/;CMakeCache;gz$;Makefile\\\\.;trace;Testing/;foo;autom4te;cmake_install;CPack;\\\\.pem;ltmain.sh;configure;libtool;/config\\\\.;missing;autogen.sh;install-sh;Dart;aclocal;log$;Makefile$")
+
+SET(CPACK_SOURCE_PACKAGE_FILE_NAME "${CMAKE_PROJECT_NAME}-${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}")
+
+ADD_SUBDIRECTORY(src build)
+#ADD_SUBDIRECTORY(doc)
+ADD_SUBDIRECTORY(tests)