summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2022-01-03 00:00:53 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-03 01:42:05 -0500
commitc5d55a997033e412272695f6abf26554cda17fa7 (patch)
tree6c5f3725ef0d533c2c61b2eb19a701cd326ccd21 /CMakeLists.txt
parentc7c342017f3876b3277ab231bc8b49b55c86683e (diff)
downloadlighttpd-git-c5d55a997033e412272695f6abf26554cda17fa7.tar.gz
[build] cmake build now defaults to C11
cmake build now defaults to C11, like meson build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f4d4973..cd665b61 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,9 @@ project(lighttpd C)
cmake_minimum_required(VERSION 2.8.2 FATAL_ERROR)
+# use C11 with CMake >= 3.1
+set(CMAKE_C_STANDARD 11)
+
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/scripts/cmake)
include(CTest)