summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eb@emlix.com>2022-09-21 10:28:00 +0200
committerGlenn Strauss <gstrauss@gluelogic.com>2022-09-23 03:39:22 -0400
commitf98cc6743821b8bfa342dabb9a7d5a06ce6b93fe (patch)
tree6276ef4c57448f6dab3cf8bc14eca6814f433765 /CMakeLists.txt
parent07f428dc8a0c3855f8b4de960ee7f19d7c81b6d6 (diff)
downloadlighttpd-git-f98cc6743821b8bfa342dabb9a7d5a06ce6b93fe.tar.gz
[cmake] install man pages with CMake
github: closes #118
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d47bf300..a78ff7e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,6 +25,8 @@ set(CPACK_SOURCE_IGNORE_FILES "/\\\\.;~$;/_;build/;CMakeFiles/;CMakeCache;gz$;Ma
set(CPACK_SOURCE_PACKAGE_FILE_NAME "${CMAKE_PROJECT_NAME}-${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}")
+include(GNUInstallDirs)
+
add_subdirectory(src build)
-#add_subdirectory(doc)
+add_subdirectory(doc)
add_subdirectory(tests)