summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2021-12-14 01:07:29 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2021-12-15 06:38:52 -0500
commit0ebcfbd7d6699d73bc6709e52dc3910e32cbbff9 (patch)
treebe452fe03f2a04374ce52b61d39a95df025ef55f /configure.ac
parent0ba74e23816b9d844944f90b85e6c448864dfcdc (diff)
downloadlighttpd-git-0ebcfbd7d6699d73bc6709e52dc3910e32cbbff9.tar.gz
[build] add headers for sendfile() detect on MacOS
(thx ryandesign) x-ref: https://github.com/macports/macports-ports/commit/d636f118f49297c7e35d57444f64021f7ce45bc5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index edc4883c..2a6d5de1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1612,6 +1612,9 @@ if test "$ac_cv_func_sendfile" = yes; then
#include <sys/sendfile.h>
#endif /* HAVE_SYS_SENDFILE_H */
#include <errno.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/uio.h>
int main() {
int o = 0;
if (-1 == sendfile(-1, 0, &o, 0) && errno == ENOSYS) return -1;