summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2021-02-10 08:10:17 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2021-02-10 08:10:17 -0500
commit28fc51c74731359b1cbf42f1543e12e2cd899f10 (patch)
treede112bbd66b60f7c83d9abdea4b22c49eff42027 /configure.ac
parent46269cf3a3577a9a068829366e6f6077cf7a3888 (diff)
downloadlighttpd-git-28fc51c74731359b1cbf42f1543e12e2cd899f10.tar.gz
[build] augment configure.ac msgs to remove FAM (#3068)
augment configure.ac msgs to remove FAM on linux and *bsd x-ref: "stat-cache-fam feature appears disabled since 1.4.56" https://redmine.lighttpd.net/issues/3068
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 29 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1030fda8..9dc0205e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1064,7 +1064,13 @@ AC_ARG_WITH([fam],
)
AC_MSG_RESULT([$WITH_FAM])
-if test "$HAVE_SYS_NOTIFY_H" != no; then
+dnl "$ac_cv_func_kqueue" is set further below
+case "$host_os" in
+*bsd*|*darwin* ) WITH_FAM=no ;;
+* ) ;;
+esac
+
+if test "$ac_cv_header_sys_inotify_h" != no; then
WITH_FAM=no
fi
@@ -1801,8 +1807,30 @@ lighty_track_feature "network-ipv6" "" \
lighty_track_feature "large-files" "" \
'test "$ENABLE_LFS" = yes'
+case "$host_os" in
+*linux* )
+lighty_track_feature "stat-cache-inotify" "" \
+ 'test "$ac_cv_header_sys_inotify_h" != no'
+ ;;
+* ) ;;
+esac
+
+case "$host_os" in
+*bsd*|*darwin* )
+lighty_track_feature "stat-cache-kqueue" "" \
+ 'test "$ac_cv_func_kqueue" != no'
+ ;;
+* ) ;;
+esac
+
+case "$host_os" in
+*bsd*|*darwin*|*linux* )
+ ;;
+* )
lighty_track_feature "stat-cache-fam" "" \
'test "$WITH_FAM" != no'
+ ;;
+esac
lighty_track_feature "webdav-properties" "" \
'test "$WITH_WEBDAV_PROPS" != no'