summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-01-19 17:57:32 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2023-01-19 22:14:17 -0500
commit6516c5a2d4a310014df3ccba04bcaa39b7b28b83 (patch)
treea77392a4c45c9463dd9325bedb0b46a6b2fb88b0 /configure.ac
parent48033debc4e107cf53311cc809c4ca83fb8b3ba3 (diff)
downloadlighttpd-git-6516c5a2d4a310014df3ccba04bcaa39b7b28b83.tar.gz
[multiple] clang -Wstrict-prototypes for C2x
adjustments to compile warnings-free with recent clang changes that warn about potential behavior change for non-prototypes, including generic function pointers e.g. int(*)() x-ref: https://discourse.llvm.org/t/rfc-enabling-wstrict-prototypes-by-default-in-c/60521 https://www.open-std.org/jtc1/sc22/wg14/www/docs/n2432.pdf https://www.open-std.org/jtc1/sc22/wg14/www/docs/n2841.htm
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7fcba4b3..8aa15dad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1525,7 +1525,7 @@ if test "$ac_cv_func_sendfile" = yes; then
#include <sys/types.h>
#include <sys/socket.h>
#include <sys/uio.h>
- int main() {
+ int main(void) {
int o = 0;
if (-1 == sendfile(-1, 0, &o, 0) && errno == ENOSYS) return -1;
return 0;